Humming again.

Posted by fonitronik

It has been quite a while since the POLYSIX is working again, i just forgot to share the video of proof here. There is still some work to be done, though. I will have to realign the front panel components PCBs (center the postentiometers again), and i will replace the momentaries. The replacements are already waiting in the drawer.

Mew!

Posted by fonitronik

The new opto arrived yesterday. Since everything was prepared already (socket installed) i just had to put the new opto in it`s socket - and now the POLYSIX is purring like a cat again!

While playing with the synth i recognized two weak program switches. Now i will have to find those replacement switches i bought a while ago...

Recap

Posted by fonitronik

While i am waiting for some replacement parts i started to replace the old electrolytic caps of the PSU.

PS-010TN

Advanced Optics

Posted by fonitronik

Now the KLM-366 is on the bench.

Stefan Hübner has some good info on the opto coupler in the Polysix' Antilog circuit. And thanks to his article i am able to almost be sure that the scale issue is caused by an error in the Antilog circuitry. I measured -13V at pin 7 of IC 18, indicating that something is not working as expected here.

Making contact

Posted by fonitronik

Every now and then i did some cleaning of the keybed. Hard to find the time, nevertheless, i can't wait to have it working. I used a pencil eraser, spirit and finally IsoProp to clean both the contacts of the PCB and the contacts of the rubber switches. I am looking forward to reassemble and test my work...

PS-007TNPS-008TN
PS-009TN

Optocoupler isn't coupling anymore!?

Posted by fonitronik

Ko Okatake of modelessfactory/Japan pointed me to the P1501 optocoupler, which will most likely be the cause for the wrong scale. I just ordered a NOS replacement part from Australia - so now i have plenty of time to disassemble the keybed and clean the contacts.

Out of tune or out of scale?

Posted by fonitronik

Obviously the latter.
Playing unisono all voices are in the same tune. When playing a chord it sounds always detuned in the same way, no matter in which order the notes are played. So the voices are in tune to each other. It is just that the overall scale is wrong. This should be easily corrected by trimming the antilog function block. The service manual does not say that much about it, though.:

PS-006TN

Memories can't wait.

Posted by fonitronik

Today i cut and bypassed all polluted and corrupted traces/vias, and i installed a new CR2032 3V battery. The KLM-367 is inthe synth again, and works as expected.

So far i just tested the programming and recalling of a sound, even after powering off. All good! Hurray!

Thank you, Scott Rider aka oldcrow!

Next: calibration (sigh)

Fresh Nylons

Posted by fonitronik

The KLM-367 repair is almost done. Meanwhile i replaced the heavily oxydized screws on the front panel. For the M3 screws that hold the front panel components PCBs I opted for black nylon screws. They have a nice shiny surface that fits very well to the actal panel - and they won't oxydize again...

Additionally i cleaned the panel with some isoprop and removed all the knobs for washing them up.

Traces of concern

Posted by fonitronik

Meanwhile i extracted the KLM-367 board and removed the old battery. A more thoughly examination of the traces revealed that previous repair has not been sufficient. They obviously just cleaned the PCB on the surface and replaced one trace underneath the IC31 AND gates by a wire.
So the acid of the battery leakage continued destroying some traces and vias.

I marked all affected traces on hte PCB printout. To remove and replace all bad traced it would be the best to remove the socket of IC31 completely.Something i actually wanted to avoid, since this would be the 2nd desoldering action on this footprint - and each PCB has its limits... on the other hand i don't want the acid to degrade the PCB any more.
One solution could be to cut the bad traces, but not remove them. This way the acid cannot crawl any further and i would most probably not have to desolder the IC socket.

PS-006TN

The battery leakage problem

Posted by fonitronik

After opening the unit i was more than just relieved. The battery installed still showed no signs of leakage. So i powered the synth up. Yes, no proper sounds, but this was what i expected anyways. I quickly recognized that i could program a new sound, all controls of the sound engine obviously still worked. A few keys of the keybed where not working. Another thing i expected. However, the unit is totally out of tune and need a complete calibration procedure, i guess.
Nevertheless i stopped any testing here, leaving the memory functions alone. I wanted to install a new CR2032 battery first.

Now i took a closer look at the KLM-367 and quickly saw that someone must have been done a leakage repair at some point. Most probably long time ago, since they installed another old NI-cad battery again...Anyways, i saw that the AND gates near the battery have been replaced and socketed, and the solder stopmask was dull. Obviously they had removed the acid from the battery leakage only on the surface, and meanwhile the acid did some damage to a few traces. But i think the damage is not too bad, as you can see in the picture below. I spotted one affected trace near the AND gates (IC31), and the wide GND trace has been affected on two spots. Doable, so the board will not have to be replaced.

PS-005TN

The journey begins...

Posted by fonitronik

A few days ago I snatched a broken KORG POLYSIX, a pig in the poke, actually.

As i've been told the former owner bought it exactly 30 years ago, used it for about 10 years, and then stored it away for 20 years. Just recently he plugged it in for the first time after 20 years and all he heard was some strange noises, he said. I suspected a battery leakage.

Now here she is. And the first look gave me a sense of foreboding: heavily oxidized screws, some rust blisters here and there... My fear was that the acid of the battery leakage might have wreaked it's havoc for years, destroying the KLM-367 memory/controller PCB beyond repair. Anyways, on the first day i had no time to open it up and take a closer look.

PS-001TN PS-002TN
PS-003TN
PS-004TN